Documenting issues related to inconsistencies in the Queue Behaviour

hey @steveaw, thanks for reporting this, I am currently compiling all such related inconsistencies, and will have a report sent to the team soon.

I cannot tell yet since I was not able to update the Mac App so far. After this is fixed I will report back.

I’ve been using beta 1.3.7 for a while, and the problems reported was solved, as far as I could see.

1 Like

got it thanks, hopefully we get that fixed soon

That’s great, so there hasn’t been any abnormal behaviour in the scheduler that you have noticed?

New user to RemNote.

I am using the default scheduler.

I have a card with the following history:

It is giving me the following answer intervals:

Screenshot 2021-05-04 090900

These seem too long to me. Am I doing something wrong?

@hugo @anisha @88DM88 any thoughts regarding this, as you guys were having a discussion similar to this elsewhere?

Yeah those are definitely wrong intervals.
The meta data as well looks wrong to me because the smallest interval of the default scheduler is 24 hours.

I‘ve personally never run into this issue before because I don‘t use the default scheduler but I can make some guesses as to why this is happening: Did you use the anki scheduler during your pro trial? Maybe that somehow messes up the scheduler once your trial is over

Yes. I did have the anki scheduler on for some reviews, and then switched back to default. (I did upgrade to pro before the trial ran out, so it wasn’t forced back to the default).

Then in that case this issue happens when you use Anki first and then shift to default later?

@steveaw have you been facing this issue for new cards that were made after the change to default algorithm?

That seems likely, although I have not tested it

I am not switching between algorithms and have not seen the issue again with newly created cards

Hope this helps!

I had another episode of card duplication/different queue size across devices issue today. Opened remnote on a Windows/chrome computer (computer2) that I had last used/synced around 2 weeks ago. Queue jumped from my main computer at 212 to 530 on computer 2 (unfortunately when I went back to the main computer and it synced, its queue was also 530).

Looking at the “Cards” view, I could see many duplicates. Sorting the “Cards” view by “Next practice time”, I saw all the nil review duplicate cards had the same next practice time, which was the time I synced computer2.

I am slowly going though and viewing/changing every document with the trick that @Nijat_Aliyev noted, to get rid of the duplicates: Please prioritize fixing sync issues - #8 by Karthikk

Ok, so let me try to understand the situation better:

  1. Your latest queue number is 212 on main computer
  2. You have another computer, that was last used around 2 weeks ago and the old queue number on it was 530
  3. When you opened RemNote on computer 2, it went through syncing and ended up with 530 still
  4. Now the main computer is also reporting 530 + there are duplicate cards.

is this the situation?

  1. Your latest queue number is 212 on main computer

Yes, I did a few cards from the main computer queue at midday. The queue at this time on my main computer was 212.

  1. You have another computer, that was last used around 2 weeks ago
    and the old queue number on it was 530

No. I don’t know or recall what the old queue number was on the other computer 2 weeks ago.
I synced the other computer at 1PM and then the queue jumped to 530.

Now the main computer is also reporting 530 + there are duplicate cards

Yes (after it synced again).

But the good news is that, again using Nijat_Aliyev’s trick, I went through all documents, making small changes to the ones with duplicates, and that eliminated the duplicates so that the main computer’s queue is back down to 212.

I don’t dare open remnote on the other computer as I don’t want to have to go through that process again to fix it.

FWIW: When I quote queue numbers, I am not going off the sidebar number. I am quoting the queue size number in the review window, after ensuring a sync has taken place

1 Like

I have a nice example of strange queue behavior here (anki scheduler).

Maybe I misunderstand the way the scheduler works, but even if I rate every repetition as ‘hard’, shouldn’t the time interval grow?

No. If you press “Hard” every time, the card will never leave the learning phase. After leaving the learning phase (after the card “graduates” or enter the exponential phase), pressing hard will increase the interval just a little.

But I think you missunderstood the behavior of the algorithm. “Hard” means really hard (you almost forgot); it does not mean that you found the topic difficult; it means you hardly was able to recall the subject. I think it was very unlikely the case here.

97%+ of your ratings should be “Solid” (Good). Only a very few cards would usually be rated “Again” or “Easy”. Pressing them every time certainly will mess the schedule.

Hi, thanks for your reply. That’s an interesting fact. Yet, I still don’t really get it.
How does this fit to cards like in the screenshot below?
That is how I thought it is meant to work and how the majority of my cards actually behave. The card is in the exponential status, although I always rated hard.

I have been using RN quit regularly over the past weeks, and now I get the idea my scheduler is somehow stuck. Even if I rate a rem Easy a couple of times in a row, the next interval stays 5 days. This way my queue becomes longer and longer!

If I calculate the interval with Multiplier * (Last Scheduled Interval + Days Late / Hardness Divider) it would be 2.5 * (5+ 0/1) =12,5 days.

After reading the forum I tried the suggestion of using the app, but then a rem appears in my queue 2 days early.

I get to choose between immediate, 3, 5 and 5 days, which doesn’t make a lot of sense to me either.

Am I getting it wrong or is something the matter with my knowledge base?

Ok, there is definitely something weird with my scheduler:
Now after a couple of times of 5 day intervals, the interval suddenly jumped to 3 years!
One rem:

Another rem:
Screenshot 2021-08-26 at 12.27.26

Why the enormous jump in time all of a sudden?

This is from the next day. The ‘Ease’-factor and the Phase are no longer in the description, and choosing Easy resulted in a giant leap from a 5 day interval to a 5 year interval.

What is happening?!

1 Like

Did you change your “Custom Scheduler” type from “Anki SM-2” to “Default” type between your first and second post?

In your first post, “Phase: Exponential” was exhibited (this means that you were using Anki SM-2 scheduler).You would have to show us your settings, specially “Maximul Interval” (to see if it was not incorrectly set to 5 days).

If you latter changed to the Default scheduler type (in your second post the phase of the card was not exhibited, indicating that the scheduler type was the default), there is no maximum interval in the default, and probably the many times you pressed easy increased too much your factor; anyway, the interval could not be so long.

Please give us these additional info (showing your settings and telling us when you do sth important, like changing the scheduler type in use).

Thanks for your response, but I am not a paying member. I can’t choose a scheduler, so I did not change anything between the two screenshots, accept look at my queue in the Android app.

Is it possible that the scheduler I used in March (when I had the full version to try out) was still somehow on? These rems in the screenshots were all created in the last 5 weeks, so RN should use the default scheduler.

1 Like