Adding a template. blue number does not show up


I am trying to add a template. I have read the tutorial as well as the youtube videos by Mike and Matty.

The issue I am having is that the blue number to add the slots does not come up for me to manually add the slots in.

What am I doing wrong?


Post screenshots of what your template with slots looks like and what the rem you are applying it to looks like. Here’s an example, as you can see, it works fine as long as you’re doing everything correctly.

Hey there

according to the videos and tutorials when I tag a rem with a previously made template, it should give me the template but it doesn’t seem to. Is there anything else you can think of?


From your example, try tagging “testing rem” with “template rem” rather than tagging them both with whatever “Journaltemplate” is. Also just to double check - you are on Pro, correct?

Hi there

didn’t make a difference.

I paid as a ‘lifelong learner’. So I assume all the pro features are automatically on.

I have reported this as a bug, as well as the fact that my search function still does not function. I am still waiting to hear back from the Remnote team.

Again, it looks like you are tagging with some other rem that has an uppercase T. Here’s a vid starting from scratch of what should happen, including all key presses (ctrl+shift+s is copy tag of this rem, ctrl+alt+s is turn into slot). Automatically adding slots also works, but I figured may as well show that the slot selection popup also works.


It looks like it works brilliantly on your computer. But it does not work on mine.

Furthermore, on my computer and my ipad when I try to make hashtags, it will capitalise every word even if I have put it in in lower case. So it is interesting to me that you can do lower case hashtags in the first place.

The summary so far is that templates don’t work, the search function still does not work, and I now it seems that I cannot make tags that are in lower case.

Can you take this tag and test it again … and rename the template rem (cause it seems there are 2 rems with the same “random thing” name … one a tag and another this template rem)


I think I am starting to get somewhere but I am still running into problems. I am going to use an actual example of what I mean as before I was just using the word ‘rem’ and because there were so many uses of the word I felt like I was in an Abbot & Costello routine and I was getting really confused and frustrated.

so this is the template I made

then I made a new rem with ‘morphine’. then I press on the ‘drug mechanism’ and press command + shift + S which copies that rem.

So I am pleased that it finally works. but here is my next problem, I don’t want to use command + shift + S. This is inconvenient as every time i wanted to use this template I would need to navigate to this page and copy it, then go to the next page to paste it. I would rather just find it as a rem by pressing ## and find ‘drug mechanism’.

But when I do this it is not there, so i have to make it. and when I do it comes up with “Drug Mechanism” (notice the upper case now) but this is a totally different rem. I think this is where I was continually going wrong before.

so my question is, why can’t I find the template ‘drug mechanism’ using ##?

I am suspicious it has something to do with my search function not working correctly. Like I said before and in a previous post, I still cannot find plain text using the side bar or using command + P, only previously made tags, references and flashcard question headings can be found.

Below is a search done on the sidebar. I am pretty sure it should find plain text should it not? pressing command + F and searching plain text in this document also cannot find it.

That is indeed the crux of the issue: the text of the rem has no bearing on what slots it has (all rem are identified by their unique alphanumeric id, not their contents), so your newly created rem doesn’t have the slots, and so has nothing to suggest when you use it as a tag template. The rem is capitalised since it was newly created from search, you can turn this behaviour off in settings via ticking “Automatically Capitalize From Search”.

I’m afraid you’ll have to manually navigate to the template rem (perhaps store all templates in a pinned document for easy access, or pin “Automatically Add Template” powerup and use its backlinks) and copy-paste its tag until your search issues are resolved. “Reload search cache” in settings, if that doesn’t help, “Report Bugs” from the lower right ?.

Hi there

Okay I think I have found the problem. in the settings there is an option of “only search concepts” which is on by default. once I unticked this everything works.

apparently you can use alt + C to do this as a shortcut as well but I cannot figure it out on mac.