Adding / removing prefixes displayed with links

I’m noticing that in some scenarios, when I link to another rem, I see a prefix of the linked rem’s parent rems displayed as part of that link. Other times, when I create a link to a rem, those do not show up and it looks more akin to a “regular” hyperlink.

Does anyone know what characteristic or setting drives this? I’ve compared everything I can think of with no luck. Also, this persists even when I cycle through the show / hide full name options. It also happens both for links embedded within other text on a rem or for links that are the sole contents of a rem.

Here’s one with the hierarchy

compared to one without

Update to this: cc @anisha

Your suggestions worked for almost all cases. However, I am still seeing some scenarios where, even after hiding full name, a parent rem is still displayed in the link. Any other ideas?

Hi, I also have some similar experience and I’d like to share to see if it could help with your situation. My finding is that, when “Rem A” is a “discriptor”, the parent of Rem A will show up when making rem reference to rem A. But wen rem A is a “concept”, then rem A itself will only appear in its rem reference. I don’t know if this could help but maybe it’s a clue.

@Echology - That was it. Thank you for solving the mystery.

Adding a note here related to Echology’s message above. What I ended up doing to achieve this is actually switching the rem back to a “plain” rem rather than a concept - i.e. neither a concept nor a descriptor rem. In my app (Linux desktop - 1.2.3) There is not a way to do this from the menu directly but if I select “plain card type” on the rem which is having the parent rem displayed in its link, that will change the rem back to a text rem (as best I can tell) and then the links to that rem will no longer display parents.

There could be two reasons:

  1. In the example you’ve given with the hierarchy, all the rems superior to Anti-Fragile (book) are references themselves such that when you try to reference Anti-Fragile (book), the parents are visible too.
    See more here.

  2. More likely situation: You have somehow enabled ‘Show Full Name’ from the right-click menu of the reference here.
    It looks like this → image You can disable this by right-clicking the reference > Hide Full Name.

Thank you. When I tried doing hide full name earlier, it wasn’t fully collapsing all of the superior rems’ titles but when I tried it again, it seemed to work.