Documenting any Keyboard Shortcut related bugs

Hey everyone, I have been noticing that a certain subset of users have been having issues with keyboard shortcuts not functioning the way they are supposed to. This is an attempt to bring together all related issues, so that it becomes easier to figure out where the underlying problem is.

To start with, I have found that certain shortcuts involving the OPT key on Mac to not work as desired :

Opt + C and Opt + P in the hierarchical search doesn’t work on Mac.
It simply types the alternative character instead.

What have you been facing difficulty with?
Kindly give as much detail as possible, everything helps.

Not sure if that’s what you’re asking for but here are some bugs I reported

This symbol ^ causes problems · Issue #135 · remnoteio/remnote-issues · GitHub Edit: has been fixed recently

(not only ^ is affected btw but also ‘)
From what I understand, keyboard issues happen due to RemNote not being optimised for other keyboard layouts other than US. Changing my keyboard layout fixes both of these bugs I reported. I use a Swiss layout but from what I heard, there are issues on the German layout, Chinese, Korean, French, Spanish, as I said it’s probably all layouts besides US. Here’s some related text but nothing new

2 Likes

Using browser option on windows

pin document can only do pinning but not unpinning
to do so you have to revert back to the add document tag or in this case undocument

Keyboard shows no difference in wording from Add a Portal Ctrl + S to Add Portal
Ctrl + Shift + Enter

Toggle Private Ctrl + Shift + Alt + P works to toggle on. However no toggle it off except hit button for 1 hr

Calendar does not seem intuitive. Not sure if designed that way or not working
If enter tomorrow etc no issues
If need to go to other dates via keyboard issues
Mouse seems fine

All I have noticed ATM

I have left all srs components out & anything I don’t know how it functions for obvious reasons

Thank you for this! exactly what I am looking for.
Will keep collecting issues in this thread, so as to make it easier for the devs to tackle them all.

Do keep adding, if you come across anything more.

1 Like

In general Ctrl + Alt shortcuts are buggy on Windows on layouts that have an AltGr key, because Ctrl + Alt is interpreted the same as AltGr on Windows.

Also only some of Ctrl + Shift + Alt combinations are randomly not working. I use those often for plugin invokation and some letters just don’t get recognized. I have not found a pattern there yet.

  • Ctrl + Shift + Alt + D for example does not work at the moment. I remapped it to Ctrl + Shift + Alt + G which is fine.

@erikhaze has compiled a list of all shortcuts that need to be remapped on german QWERTZ on remnotekurs.de. Basically most things with a special character like ;/' etc.

2 Likes

Thank you, Hannes, for remembering my shortcuts :slight_smile:

Yes, Germans use different shortcuts for special characters (sometimes we use shift, while on an US keyboard it can be accessed without shift) and also we use different apostrophes '`´, I think there are perhaps 10 apostrophes, but the US apostrophe is not accessible on a German keyboard.

As a consequence, Germans can’t use the standard shortcuts the way they were intended. I assume other languages will have similar issues.

Well and then there is of course the different browser / different OS issue, that also causes problems. I use Vivaldi on Linux for example.

2 Likes

Thanks for the feedback & will do

Will be testing other areas vs hotkeys but will update if I come across anything

1 Like

Hello there! I had experienced this problem on a British keyboard. I think that there is a problem when the shortcuts involve ‘alt’ (/‘option’). Eg. Go to Documents Table = command + option + O didn’t work well. I am using Mac (Desktop App) with a British keyboard.

My solution for that, was to reset all the faulty keyboard shortcuts. In the above example, I typed command + option + O on my British keyboard during the resetting. It looked like this after it:
image
It looks a bit strange but the shortcut works when I type it. Unfortunately, I think this feature is only accessible in premium and grandfathered versions (?).

I hope this extra piece of information helps. Wish you all the best and a good day/night ahead.

1 Like

thank you for sharing this! definitely helps :slight_smile:

1 Like
1 Like

The option to change the quotation mark should also be added.


It would help me work around some bugs that are longer term down stream issues like
a bug where to activate the quote block you have to type the quote mark 4 times which also creates unnecessary quote marks and another bug that makes your cursor jump to the beginning (This symbol ^ causes problems · Issue #135 · remnoteio/remnote-issues · GitHub)

Of course fixing the longer term down stream issues would be a solution too, all I care about is that I will be able to use the quotes for searching without having to deal with the bugs as soon as possible.

Edit: Actually forget that part with the 4 quote marks, I just didn’t know how to use it correctly. On my keyboard layout the remnote quote mark is intended for accents only so to use it not as an accent, you have to press spacebar afterwards. Ignoring the issue I reported on github, the input for quotes on my keyboard is quote mark+spacebar+quote mark+spacebar. So yeah, the option to change the default quote marks would be very beneficial after all for people with similar layouts like mine and like I mentioned already, it would allow for a quick and easy workaround for the bug I reported on github.

1 Like

Hi!
I’m trying to remap the new delete Rem combination but Remnote can’t accept the backspace key.

Related Report from @hannesfrank : Global Shortcuts (Operating System/Desktop) have localization issues which cannot be solved by remapping · Issue #377 · remnoteio/remnote-issues · GitHub

Hello I’m not certain if it is a bug or me being an idiot:
I can’t make use of the shortcut for a quote:
image
I’m working on a belgian french keyboard, I’ve many of the accents and appotrophies, but I can’t make it work.
Any idea?

The Ctrl+Alt+Shift+D (to tag a rem as document) does not work.
Surprisingly, it does work on the sidebar to untag a document.
[Have tried on both Mac and Windows but the issue is still there]

See if you can fix this, devs. You’re doing a great job! :))

2 Likes

I just checked with my web app on MacOS, it seems to be working fine. Are you having difficulty on the desktop app?
Also can you double check if this is the correct keyboard shortcut assignment for you? You might have accidentally changed it

Related report in GitHub : Issue with keyboard shortcuts · Issue #510 · remnoteio/remnote-issues · GitHub

1 Like