Exporting create empty zip file

Not sure why but when I export now I get an empty zip file. I’ve tried text and markdown export with the same issue. And it doesn’t matter whether I use the desktop app or the web app.

Thanks for submitting this report, have you tried exporting other Rems? What’s the result in those cases?

Just checked and it does work with other rems. That was interesting so I did a few more tests and found that any rems in the document that I try to export give the same error.

If I copy it into another document it works. Do you know why this could happen?

Very weird, but good catch there!
If you don’t mind can you copy all the contents in that document somewhere else, delete that document. Create a new daily document for the same date and try again?
I am thinking somehow that document got corrupted for some weird reason.

1 Like

@dmrd has been experiencing the same issue and has reported on GitHub here : Zip file for document export to markdown/html from desktop app is empty · Issue #1099 · remnoteio/remnote-issues · GitHub

Can you please test and tell me if this issue is pertaining to a single document or all documents?

I can’t say ALL but I am seeing it happen on more documents. I am able to copy from the preview window and paste into text editor and save that way. Since I’m not exporting that often it has not been that big of a pain.

I have tested exporting all rems in my database and that seems to export even the ones that show corrupt for an individual export. But obviously I can’t do that all the time.

Hope that helps.

Could you elaborate on what you mean by preview window?

When you click export on a document it opens another window that displays a preview of the “Document to Export” so you see what it’ll look like. Instead of doing the actual export(download zip folder) I select the text from that “Document to Export” then paste it into another text editor.

1 Like

Thanks for letting me know! Could you do me a big favour and try this?
If you have other knowledgebases, try to play around and see if this is happening there as well. I am trying to understand if this is a result of some corruption in a single KB.

Another related GitHub report here :

User gets a blank zip file while trying to export as MD.

This problem also exists when exporting from the web

1 Like