How do I find a missing power up rem?

there is no power rem when i type the hashtag (##), it does not pop , the extra card detail

Not listing Power Ups in “Concept only search” seems like a bug to me. If disabling this setting does not work for you (for example you renamed it and forgot the name) you recover it using (Chrome) DevTools.

Press F12 to open the DevTools and paste the following script into the Console:

d = {
    "a": "Automatically Sort",
    "c": "Custom CSS",
    "d": "Daily Document",
    "e": "Edit Later",
    "g": "Tag",
    "h": "Highlight",
    "j": "Emoji",
    "m": "Automatically Add Template",
    "o": "Document",
    "q": "Thought Queue",
    "r": "Header",
    "s": "Document Sidebar",
    "t": "Todo",
    "x": "Extra Card Detail"
};

openRequest = indexedDB.open('lnotes', 22)
openRequest.onsuccess = () => {
    let db = openRequest.result;
    let t = db.transaction('quanta');
    let quanta = t.objectStore('quanta');
    let request = quanta.index('rcrt').getAll();
    request.onsuccess = ()=>{
        console.info('Power Ups:');
        for (let powerup of request.result) {
            console.info(d[powerup.rcrt], `https://www.remnote.io/document/${powerup._id}`);
        }
    }
}
openRequest.onerror = ()=>{
    console.warn('There was an error:', openRequest.error);
}
openRequest.onupgradeneeded = ()=>{
    console.warn('The database version has got an upgrade. Update this script!');
}

Then click on the link to the power up you want.

Doing it the hard way

First, find the abbreviation letter for the Power Up you want to find:

a: Automatically Sort
c: Custom CSS
d: Daily Document
e: Edit Later
g: Tag
h: Highlight
j: Emoji
m: Automatically Add Template
o: Document
q: Thought Queue
r: Header
s: Document Sidebar
t: Todo
x: Extra Card Detail

Here is how you would discover the Power Up Automatically Add Template:

What exactly are you looking for? You can find the power-up rems in the special menu, typing / and then browse through the letters a, b, c etc.

Hannes Frank also created a list of power-up rems:

The new update. The extra card detail. I want to use that update. But even the special menu typing / does not appear the extra card detail.

The new update. The extra card detail. I want to use that update. But even the special menu typing / does not appear the extra card detail.

Ok, I think you activated the “only concept search” in the settings. See screenshot:

Can you either deactivate it (as shown in the screenshot) or press ALT + C while you search for the power-up rem.

it was helpful. thank you. :grinning:

Hi everyone,

I was trying to use Custom CSS & Active Recall.

I don’t know what I have done wrong, but the Custom CSS Power-Up has disappeared.

I tried the script given by Hannes and got the following error message:

Do you have an idea of what went wrong and how to fix it ?
Many thanks
M.

The IndexedDB (the browser database for RemNote) is probably not called lnotes anymore. The actual name varies from user to user so I can’t update the script. Usually it’s something like remnote-RANDOM_CHARACTERS. Try following the “Hard Way” (it’s actually not hard) and get the rem id manually. Do it for all databases in DevTools > Application > Storage > IndexedDB if necessary until you find it.

Thx Hannes for your quick answer :slight_smile:
Issue solved.
I had actually (when ? how? :face_with_monocle:) erased the “title / header” of the “Custom CSS” power-up.
I didn’t realize that those were “mutable” and could be deleted by users…

I’ll be carefull now.

Thx again
M.