IFTTT Webhook returning error

Hi! I’m trying to set the Webhook in the IFTTT but i’m getting: Action failure message: Unable to make web request. Your server returned a undefined.
What could I doing wrong?

  1. https://api.remnote.io/api/v0/create
  2. Post
  3. application/json
  4. {
    “apiKey”:mykey , “userId”:myuserID , “text”:"{{UserName}} - {{Text}} - {{LinkToTweet}}"

Looks good to me. I hope you have wrapped the api key and user name in " as well. Is this a fresh API key? If not, make a new one.

Also you probably want to set a parent id instead of making a bunch of top level rems you never find again.

Yeah. Tried with a fresh API key, full access and still the same error.

Sorry, just tested myself. It is definitely not on RemNote’s end. Works like a charm for me.

Try executing this in a DevTools console after you replaced apiKey (32 character string!), userId and parentId with your values:

(await fetch("https://api.remnote.io/api/v0/create", {
  method: 'POST',
  body: JSON.stringify({
    apiKey: '8c52...',
    userId: 'PJw4...',
    parentId: 'SHJE...',
    text: 'Hello World!'

You should get the id of the new rem as a result:

Promise {<pending>}
  [[PromiseResult]]: Object
    remId: "5fc..."

Thank you, it’s working! Devtools without " wrapping, IFTTT Webhook with " wrapping "text": "{{UserName}} - {{Text}} - {{LinkToTweet}}"