Option to not automatically add space after references

I took a look and didn’t see this mentioned elsewhere, so I’ll bring it up here.

In creating a Rem Reference, a space is added after it. I am not sure this is needed and would prefer if it did not happen.

  • I can see the convenience in that when adding one in the flow of typing, but since I will naturally add a space after a word, I often add an additional space and then delete it.
  • After writing a sentence I may go back and add a Rem Reference to a word. This adds a space that I then have to delete, since I already had one in between that word and the next. That creates friction and jumps in my train of thought.

Rem References with the format " | Rem Reference " add additional white space in front of the reference. This is confusing for two reasons:

  • There is usually already a space before a reference, and the additional white space creates a kind of jump in the flow of the text. So when I am reading my eyes don’t move smoothly from one word to the next and they break my train of thought not insignificantly.
  • That space paired with the "| " adds an additional jump in flow. I much prefer the Rem References that I create that don’t have the bar, but the functionality of each is different.
  • Suggestion: Remove " | " and instead color the background of a Rem Reference pale blue. Could be something else too, but the end effect would be that the white space between words is consistent.

Thoughts?

I also would like the removal of automatic spaces after a reference. This is undesirable, especially when retroactively turning a word into a reference (as you have mentioned with it adding an unwanted additional space) and when using punctuation (! ? 's . , / etc)

You can actually get rid of the vertical line with custom CSS.

Try out the following code.

/* this gets rid of the vertical line in front of all tags and all links */
.rem-indented-indicator {display: none !important}

.rem-reference-container {font-size: 12px; letter-spacing: -0.5px; font-style: normal}
.rem-reference-link {color: blue}

2 Likes

This is perfect, thank you!

Is there a way to get rid of the extra space behind a rem reference, preferably without using custom css?

Without using CSS, in settings under Labs, there is also an option to turn off the vertical line | :

vertical

Thanks, but that is already turned off. It still puts an extra space behind the reference. So there will be a space before a dot (see example “Hertz .”) or two spaces between two words.
It no life or death situations but it distracts me.