Problem with Portals/Queue

here is my problem:

I have created a document called “learning”. My intention is to create portals to all the documents I want to study in one session.

However, either none or only some of the flashcards that should be in the queue are displayed when I hit the “spaced repetition” button in the top right corner.

I know that there is the “embedded queue” feature, however if I click on this, it doesn’t show me any flashcards as well. On the other hand, if I enter the document “by hand”, i.e. I open it directly, plenty of flashcards appear in the queue.

Is this a bug? Am I doing something wrong?

I’d really appreciate any kind of advice, best regards Tobi.

From the Remnote guide, it looks like you have to expand all the rems you want to be tested on when you’re using a portal in a document.


I have already tried that after watching the YT tutorial, but that doesn‘t help either :man_shrugging:t3:

In the YT video it works somehow, but in my DB it doesn‘t somehow.

I see what you mean now. I can’t get it to work too.

Weird, works for me if the number of due card is accurate. I got 33 cards total in my queue right now and created a document with two portals to two other documents. Opened the document queue and got 20 due cards, which seems about right. I also clicked on the folder symbol to check how many cards are due and I got 11 for one and 9 for the other document, which equals 20.

Oh, I think my problem was that my cards weren’t due yet, which is why it wasn’t showing even if I expanded the children.

I tried it too. “learning” document with portals shows about 50 flashcards in the document queue, but when I went to an original document it was 300 more

1 Like

Yeah that‘s absolutely the problem. There are some cards in the queue but much less than in the documents itself.

Did you expand every single parent?

Yes I did.

Should be about 100 cards due though.

Going by the first image there are still some cards hidden, maybe these are the ones that are due because I tried it again and again and it always seems to work for me.

Ok now I expanded everything that is possible. In the queue are 18 cards due now. However, if I click on the first document and check the queue there directly, there are about 50 cards due. Despite the fact that I expanded really all lines that are possible to expand. I also tried it out on the desktop app but it’s the same there.

Yeah sorry, my mistake you only needed to expand it like you’ve shown in the image.

I guess this is a bug that I can’t replicate in my knowledge base.

1 Like

Thanks for the detailed information, we will look into this as soon as we can.

Meanwhile, if you can provide any further information regarding this behaviour, it would be really useful in helping us reproduce the bug.