Why Are/How to Stop Folders & Docs from 'Hiding' all my rems?


All of my notes/rems in my docs are hidden when I open RemNote and this is making this otherwise wonderful tool almost unusable for me. I need to be able to open a document & pick up where I left off, able to see the parent/children notes and either restructure or read old notes to brush up.

Right now the only way to get them back is to hover over the little arrow to left of bullet point and half the time that makes the menu pop out b/c its so close to the edge- PLUS it doesn’t reveal all the child rems so I have to click my face off to see the rems.

I’ve looked everywhere and I can’t see anything that allows me to de-select a ‘hide’ option or to reveal etc etc but when I open the folder under each document it says how many rem are “hidden”.

This didn’t seem to happen before I opted to practice cards in the folder, so I thought I’d finish going through all the cards made by Rems in that folder but that hasn’t unhidden it either (plus i need to be able to start practicing cards & choose to stop & go back to note taking at any time)

Thanks in advance for insight/help to turn off whatever feature is hiding all my notes/Rems!

You can also reveal all ancestors with Ctrl + Shift + Down.

I think RemNote’s behavior here is that every rem remembers all rem that are shown when it is opened as a page. By default these are only the Rem you have written when it was opened. This means that if you open a child section of a Document all rem are hidden first by default.

Also related: Make folding be different from hiding

Thanks for that. Is there a way to change the setting? There are many many child/grandchild rems in my notes & the visual difference between even seeing if there is a child rem under a rem is so slight, it would be easy for me to miss. I’d like to have the default of my document be to have all rems open/revealed when I open the doc. Do you know if that is possible?

There is only Settings > Interface > Show Hidden Children Stubs I’m aware of.

As @hannesfrank mentioned, folding state should persist.

So if you have all Rems in a Document unfolded, they should remain this way until you change this. Is this not happening for you? (If it is: does this mean you’d like all subRems to be expanded every time you open a Rem, regardless of how you left them?)

Regarding this:

I agree there should be a better indicator for how many children a Rem has, or even some other metric (like number of characters). RemNote does offer an option to have the bullet size reveal the amount of children (see settings), but I don’t think it works fully.

I strongly discourage you from that. If you have large hierarchy and a parent contains 1k+ rems, the page can become unresponsive for few seconds when opened.