Existing Rem not found, but later found

I think that you turn on below feature… And Georgetown Contacts is not Concept rem… so you cannot found it…

Solution is

You just turn off this feature and You can search anything in your KB

Thank you for your response, but unfortunately, this isn’t correct. First, I do not have that option enabled, so that is not the issue. Also, as I mentioned, I have previously tagged things with this rem using this exact same procedure without any issues whatsoever. In fact, shortly after I posted this question, I quit RemNote and reopened the app to try again, and suddenly it worked!

Screen Shot 2021-08-02 at 8.47.29 PM

So, this is clearly some sort of bug that keeps plaguing me over and over again for some reason.

Thanks again for trying to help, though!


I’ve experienced this bug several times over the past month. However, if I close RemNote and re-open it, the problem is solved.

I have noticed that sometimes (children) Rem disappear, but when I open/close the parent Rem, they reappear.

Side note: (Once you find a Rem) always check that you haven’t selected one of the ‘Hide’ (/hide) functions for a Folder/Document/Bullet etc. I believe if something is hidden, then it won’t’ appear in Search.

Thanks. I never use the hide function, so that isn’t an issue for me. My main problem is that I keep making duplicates because when they don’t show up in search, I just assume that I haven’t made them yet. I’ll just have to be more aggressive in closing and re-opening the app. That said, I initially started experiencing the bug in the browser-based version, so I’m not sure if quitting/re-opening Chrome would also fix it :thinking:

I’m not too fond of using Top-Level Rem because I don’t like seeing the Documents folder littered with Stubs and the issue you mentioned of Rems not appearing in Search.

Instead of creating a Top-Level Rem, here’s a suggestion: create a Document named (Georgetown Contacts) - then [back]link to that. I don’t have any problems (Browser or App) when searching for a document.

@nukesean Don’t forget to /merge those duplicates to keep all links in their proper places.

1 Like

Looks like a ton of people are having this problem but I figured I’d add to it because it is a big issue and it really does need to be fixed or else the app is useless for the intended purpose.

For me I set up the rem references in question several days ago. I used them multiple times that day and also the next day (no issues then, everything worked perfectly). Then today, a few days later, I tried to [[ add them to my notes for the day and they just wouldnt show up. (even when typing the full thing in letter for letter, word for word)

At first I assumed I had made a typo or something so I went and found the rem I was using as a reference AND the previous instances of me using the rems as references to confirm that they did in fact exist as references and SHOULD be picked up by the [[ search.

My current work around is to manually copy the rem references from the original source which is problematic since I don’t have enough screens to do this efficiently and its taking way longer than it should. This will also be an issue for rems that are #stubs since I wont always know if they already exist or not. (especially as I get further along in my learnings). I really need this to get fixed because it is a key function to how I use RemNote…

ALSO suggestion - it might be a good idea to add a tool that will search for duplicate rems that you can review and merge or delete as needed. That way when something like this happens we can easily fix any duplicates that are made during offline times and or feature bugs like this one.