Forward and back navigation buttons don't work

I’m using a local knowledge base on windows 10 desktop app and the navigation buttons don’t work, instead a “missing page not found” is seen. It’s been like this for a month, anyone with a solution?

I have the same problem! This Page Not Found also appears when I open the desktop app

Apologies for the delay, are you both facing this issue still or has it been resolved?
If still persisting, have you since made a GitHub report? (kindly share the link here)
If not, please describe in detail the behaviour that leads to this bug.
Thank you for the report!

Closing the topic for now, will re-open if still persisting. Kindly PM me with the details.

1 Like

Opening this again as @macsuva has brought to my notice that it happens for him.
Anyone else facing the issues still?

Are you guys on the latest Mac update? 1.3.6?

The problem still persists in the latest update 1.3.6 for Mac.
The weird thing is that if I go back using the back-button it says 404 -Page not found, but if I then click the forward button I see a very short flash of the page I came from, before it shows the 404 page.

Does this happen only occasionally or every single time you click on the back button?

It happens every time.

hi, I´m having the same issue on windows desktop app

Just to clarify and understand better, are you guys going back to a rem that has been deleted? hence the message?

No, it’s every time I click the back button in the app. If I use the back-button in the browser I can go all the way back to the previous rems that have been opened, but if I try the same route in the app, I get stopped by a 404 page at the first click. And then I’m stuck on that page because hitting the forward button only results in a really short flash of the page I came from and than the 404 page again.
I have to go back to the page I was working on via the sidebar.

That’s really unfortunate, but we are unable to reproduce this. We will try and see if other users are also facing this difficulty and get more details, or else this could be account specific and Martin might be able to help.

Happens with me as well

  1. 404 error always when I launch
  2. Back button gives 404
  3. Forward button doesn’t do anything

Browser version works properly for all 3 issues

2 Likes

How does this go away? when you access other rems through the sidebar/search maybe?

I’m facing the same problem since when i started using the desktop app. For me, the error doesn’t go away, everytime I press the “back” navigation button it always gives 404.

yes it goes away when you go to your desired rem via sidebar/search, it’s a navigation issue AFAIK and not any other serious issue

1st error is fine for me, since you’re just opening the app - not in the middle of your workflow, 2nd and 3rd are deal-breaker for me since they occur in the middle of my workflow, that’s why I use Remnote only via browser

1 Like

Exact same problem here like how the others have described:

  • 404 on launch.
  • Back and forward buttons from the GUI or shortcut from mouse leads to the 404 page.
  • Able to navigate to the files from the sidebar.
  • The files aren’t deleted, they exist because in the browser web app it works all fine.
    I tried with both local and synced KBs. Also tried without logging in.
    I’m on Windows 10, latest version of Remnote 1.3.6. uninstalled and reinstalled multiple times. Checked on my other PCs, have the same problem.
    My account was made before 1.1, so I have some of the pro features for free.
1 Like

Thank you everyone for the reports and detailed feedback. Looks like a certain subset of the desktop apps, both Windows and Mac are facing this issue.

We are still uncertain about what causes this error to show up only for certain users.

Can anyone remember what caused this to appear for the first time?

These errors were present from the start (launching of the app)

Backward / forward buttons were never functional for me

3 Likes