Queue font size

Could you please remove the “!important” from the font-size in this CSS? It is preventing us from customizing the font size in the queue.

At least the Custom CSS below is not working anymore (it was until yesterday). Should I use another for this purpose?

By the way, why do you use such a small font size as default in RemNote, both in the Queue and in the Editor? Have you considered at least creating an easier way of making fonts larger in the settings? The fonts look too too small for me.

@hannesfrank , could you help me here?


The !important is there to make headers small. There are a few ways to solve this:

  • Add extra rules to target headers which would need to be overwritten too when customizing the font size.
  • Use a CSS variables --font-size, --font-size-editor, --font-size-queue that can be customized and keep the !important
  • ? (other ideas)

I’d prefer the CSS variable way.

Note that you can also always zoom in the browser window/desktop app. (I know it’s not optimal since it distorts bullet points etc.)

There was/is a setting “Large Font” for the queue, but it does nothing in the new design for now. It will be removed eventually to reduce the number of settings and the complexity of the core application.

I think the way to go in the future is to have an easily accessible market place for CSS snippets (and extensions) and a larger font could be one of them, either standalone or as part of a theme optimized for accessibility.

1 Like

Just to mention, when I uncheck the indicated declaration on the Inspector (Chrome or Microsoft Edge), I am not having issues with headers (the headers of the breadcrumbs and documents of the hierarchy are not shown oversized).

(4. and 4.2 are headings)

Yes, you can overwrite the header size with !important like you did. If that is fine for you, you can just use

div .spacedRepetition .spacedRepetitionContent { font-size: 20px !important; }

with an extra div so it has higher precedence over the builtin one. I guess that is the simplest workaround for now. Or wait until the Custom-CSS-not-taking-precedence-with-equal-selector bug is fixed.

(Note that I’ll probably have to modify the legacy .spacedRepetition class names again when I refactor the flashcard formatting components, e.g. .spaced-repetition and .spaced-repetition__content, to fit the BEM naming scheme. CSS variables like :root { --font-size--queue: 20px; } should be a more stable solution. If you want you can add it already so it does not break when I rename the css classes.)


Bingo once more! Worked perfectly!!! Many thanks @hannesfrank!!!