Templates not showing up

I was trying to make my first template for a daily journal. I added a template called “Journalling” in the “Automatically Add template” window and added children and converted them to slots. Also tagged the said template with #automaticallyaddtemplate power up.
But it does not show up when I try to load it onto a document.
I have also checked for the Editor-setting that checks for the Enabling of templates.
I am sure I’m missing something super obvious, help.

That a good start.

To add an existing Template to a Rem, simply Tag the target Rem with the Template’s name.
To add a Tag, type ## then the name, in your case, the Template’s name, to make the Template populate wherever you want.

If you do it in the order I am, does it still give you trouble?

Hi there
Try laying it out this way

Create a document called templates
This is optional if you want all your templates kept in one place

Place journal on there as a parent

Turn all children to slots
This would now be a template

When you go to daily page & tag journal it will show up. Only the parent will show up though & not the children (slots)

However, I imagine you might want to do what most people visualize when they hear template & have the children (slots) populate when you choose your template from the Daily Page

If so, when creating your template & turning your children into slots, do this extra step

Tag the parent with the Automatically Add Template power up

Hope this helps

Hi, Thanks for the reply. I tried it in the exact same way as you suggested, still no template is shown. This is weird.

Hello, Thanks for the reply. I tried following your suggestion, but the same issue is present. No template is shown as tags. It just tries to create another rem, which is definitely weird.

I will see if I can help you better when I am home. I’m on phone & hard duplicating on Android

Do you have a template document? It almost sounds like you are making your templates on the Automatically Add Template?

If not that is odd why it won’t work

Here is a video that lays out what I am talking about since I can’t show you from phone

Yep, I tried it both ways to be frank. I saw on some video about adding it directly to the Automatically Add template and also tried doing it by creating a Template document. Super confused why such a straightforward thing is not working.

Yes that doesn’t make sense

Might be a bug then

Although perhaps wait till @Gabriela.AD pops back in to confirm as she has more experience with templates than I do :man_shrugging:

1 Like

I wouldn’t say that. You stress-tested RemNote. :stuck_out_tongue:

I couldn’t find any identical open issues regarding templates. It may still be a bug.
Sometimes bugs appear if you aren’t using the latest version of Browser or of Windows.

Could you do the following for me?

  • Check that you are a Grandfathered user (accounts created before the introduction of the Pro plans) and/or are currently on a Pro or Life-Long Learning plan. Templates aren’t available on a Free Plan.
  • Make sure that your browser (ideally you are using Chrome) is updated to the latest version, and do the same for your Operating System. Do let me know if you happen to need a tutorial for that.
  • Once all updates are done, recheck from scratch if your issue persists (mind them being case-sensitive as well). If it does, please record a GIF/Video and provide information about what browsers and operating system (and the versions) you are using.

We could escalate this to a bug report and update the Github Tracker with the appropriate information, if everything is updated and imputed accordingly on your end yet the issue persists. :slightly_smiling_face:

1 Like

Templates are nothing special, just normal rem (with slots) that are used as tags on other rem. If you can’t apply a tag to a rem then this has nothing to do with templates. It means you have a searching issue.

Maybe your issue is solved by Search not always working.

In any case you should be able to tag by /copy rem as tag (Ctrl + Shift + S I think?) and paste it where you want it (essentially skipping the tag search). Can you confirm templates are working then?


Hi. So here’s what I did :

  • I am not sure how to check if I am a Grandfathered user? I do use a Free Plan though.
  • I can confirm that both my Windows and browsers(I primarily use Firefox but both Firefox and Chrome) are up-to-date.
  • I tried to create a template document and add a rem with children slots. Still it does not show up when I try to tag any rem on my Daily Document or any other document for that matter.
    Also, I raised this issue for my desktop app at first. It is also Up-to-date. And then I tried doing it on my browsers.

This worked! I am both very perplexed and amazed at this. I copied the Rem as Tag and I could paste it with the whole of the template children.
So I guess it was always a Search Not Working bug. Thanks so much, loving this community a little bit more everyday!


Haha, Thanks so much anyway!

1 Like

Glad you found a solution

If you still can’t make the search for it occur you might want to consider adding your info to the link provided earlier. This way they are aware of the issue

Glad you can still make the templates work though


Yes, I will surely add it to the Github tracker. Cheers!

1 Like