Bugs occurring when typing Chinese in a single block

Hi Remnote Community,
Whenever I am typing Traditional Chinese in a single block on Firefox (It’s currently the only browser I’ve tried that doesn’t come across with the typing cursor issue), the following error message occurs,

“Something went wrong.
Please try refreshing the page. If the problem remains, please provide additional detail on the help page.
Error: Cannot resolve a Slate point from DOM point: [object Text],2. URL: RemNote

Has anyone encountered the same problem here? Is there a fix for this? Thanks!
Operating System: MacOS Big Sur 11.4
Browser: Firefox 89


You say “whenever”. Does that mean that every time you type traditional Chinese, you will encounter such a situation? Or does it just happen occasionally?

This happens to me occasionally. Although I am not typing traditional Chinese, it shows the same error as yours.

At this point, just refresh the page. I can go ahead and type.

Also, have you tried using Remnote’s desktop app? How is it going?


Thanks for pointing it out to specify my issue. It means “every time” I type in pure Chinese words. (The situation does not occur if I type some English letter first) I also refresh the page, but having to frequently refresh the page is sometimes quite annoying😅
Remnote on the desktop app, Safari, and Chrome will encounter some cursor issue and that’s why I’m using it on Firefox.

exactly same issue here (including the reason why use firefox)
will remnote team fix these bugs that regard of non-english language?
I really like the design philosophy of remnote, but also really struggled in the bugs that seriously affected my chinese typing experience

hi Remnote,
same issue too, does remnote team have the solution of this issue?
After update to 1.4.7, the firefox workaround is invalidation.

Please pay attention to Chinese language users, I like this tool very much and pay to use it, but the Chinese input problem on the mac device is bothering me seriously.

You can try to reproduce this issue as following,

  1. Using any MacOS device.
  2. Open anyone Remnote interface. (Desktop app, browser: chrome, edge, firefox…etc)
  3. Type chinese in any rem. (e.g. using Zhuyin input method)
  4. Press “enter”, then you can see the error message.

Me too!
iPadOS 15, after RemNote 1.4 update.

Decided to cancel the subscription temporarily, this problem affects mac users too much

I have the same issue, too!!!

Hi, I wanted to use emNote for studying Japanese, but I have the same issue (when typing i see placeholder text over the typing), also when i try to delete or enter, it deletes everything. It’s really annoying and I hope it gets fixed, because I cancelled my subscription because of it.


You can remove this placeholder with a Custom CSS code by browneyedsoul

/*********** Hide "Type / for Commands" ***********/ 
[data-rem-tags~="divider"] .rich-text-editor-placeholder {
	display: none;
1 Like

me too!!! It’s a critical issue. Now I cannot use RemNote entirely.
I reported the issue in Github.

But no one has responded so far.

For those who have been suffering from this kind of input problem, Please vote for this thread.

1 Like