Documenting the "zombie rems" and sync related issues

There used to be sync issues happening in RemNote, where Rems suddenly appear or disappear when accessed through different platforms (web,desktop, mobile). These bugs have been largely identified and fixed continuously, but there seems to be edge cases still persisting where users are experiencing Zombie Rems appearing even after deleting, queue positions not being updated across all platforms etc.,

This is an attempt to document the behaviours of such issues, so that the devs can squash the bugs altogether. Kindly share in detail :

  1. Related issues that you have faced or you have seen others post about.
  2. Specific behaviours that might be triggering such bugs (based on your testing)
  3. If it happened before for you, but you adopted some methodology and it stopped happening for you, what did you do?
  4. Related bugs reported elsewhere (github,forum, discord discussions etc.,)

The few related discussions that I have noticed :

  1. Many (many) copies of rems have been created overnight :/ (#stub and others)
  2. Syncing issues between mobile and computer
  3. Current state of SRS / syncing issues
  4. Deleted Rems/Documents reappear

I have ran into a few issues in this regard as well. I have already discussed in Discord here but in the spirit of keeping everything together in the forum I will quickly go over what I have experienced

Zombie rems keep reappearing as listed in the opening post. Often this happens from untitled rems, though those rems often have something within them as well. Also included are portals, references, tags, orphans. I am sure for those that have been around for a while you get the idea.

The thing that I have noticed that seems a little different from what others users have mentioned is how they appear on the various platforms. Every platform I go to has a different number in the document table.

For instance, RN accessed from Brave on my laptop has a different number of documents & top level rems & documents then RN accessed from Brave browser on the PC.
This same issue occurs when trying other Browsers except for Vilvaldi on the Mac has an endless refresh needed which never lets me in even after clearing the cache etc etc

This is not limited to the browser versions, though
The same issue occurs when the desktop on the PC vs the desktop on the laptop
Android number is different as well

Since this seems to be an issue that has occurred before I will presume that is won’t effect the app itself aside from making the document table unusable. This, in turn, means I will need to make sure that all Top Level Rems are actually kept as stubs vs just TLRs so that I have a functional way to track them down if I need to find them since this was the entire reason I was even using the document table in the 1st place. :thinking: I suppose one could also add a tag named Top Level Rem or something to that effect when it leaves the stub status

I’m new to Remnote and I love it, but I’m having a strange problem that just started today. There are multiple copies of all my documents in the document pane. The number fluctuates - sometimes there are two copies of each, sometimes three. If I delete one, it deletes the duplicates as well. When I create a new document, additional copies show up at the same time. I’ve attached a screenshot.

Thanks for any help you can provide!!

Screen Shot 2021-02-27 at 10.17.16 PM|638x500

By the way, I’m using the browser version. I tried clearing the cache and trying another browser, but the problem persists.

Meet same issue. And i found the desktop version is 1.2.5, but online version not change?

1 Like

is this endless refresh bug still persisting after the previous update?

The endless refresh is gone as of today
Probably due to the update from last night

All other issues in the post are still occurring, though

1 Like

Good to know as it has been fixed in the last two updates.

This is as expected, because the intention of starting this topic is so that we can document these edge cases and reproduce the bug better. This will help the dev team in fixing the issue, tremendously.

Yes, on other platforms they were gone before though periodically it happens like once a wk

The specific case I listed above was the exception that had persisted regardless of the 2 previous updates
Though fixed now

This is as expected, because the intention of starting this topic is so that we can document these edge cases and reproduce the bug better. This will help the dev team in fixing the issue, tremendously.

Yes I get that
Just was making sure I was clear on which part was fixed so there was not a misunderstanding that the issue had been taken care of

I’ve posted the link number 1 you mentioned : Many (many) copies of rems have been created overnight confused (#stub and others)

In my experience, it is partially related to content that is created by copy-pasting text “in RemNote language”.

I give (in the link) the example of content copy-pasted from my library which resemble this :

The statistical physics of cities, Barthelemy, [[Issued/2019]]
[[People/Authors/Barthelemy, Marc]]
[[Issued/2019]] in [[Journals/Nature Reviews Physics]]

This creates: #stub for (I believe) each new [[ ]] rem created, creates as many copies (I believe) as authors of the rem People/Authors, same with Issued and Journals…

However, #stub are also created randomly when I create a new rem on the fly. I’ve typed [[Cats, and now I have another #stub that only tags the rem Cats.


this is certainly a weird behaviour. I am unsure why there is a duplicate Stub. Can you confirm if there are more stubs like this?

The intended behaviour is :

  • When you create a top level rem directly from [[, it get’s tagged as a stub.
  • This helps you track empty top level rems

Can you test and tell me which Stub gets tagged when a new top level rem is created using [[.

Hi @Karthikk

My issue is there is a untitled page contains power up rems which I can not delete.

Reproduce steps:

  1. I deleted all rems in my account and re-imported the backup in Desktop version
  2. After some minutes, the issue comes again when I use the online version in new Edge

This is annoying as I have try the above steps multiple times to try to delete this untitled page.
This issue may be caused by broken rem metadata in my account in the browser indexdb?

I get the information for this Rem from devtools which I marked with title “This rem can not be deleted”

{"_id":“YNEiLrixEND7r4Kv6”,“key”:[“this rem can not deleted”],“owner”:“68ADZygAbXSEbBr7o”,“children”:[“ftwCym3raj4E2h44G”],“subBlocks”:[“ftwCym3raj4E2h44G”,“jRjmsChv7yRnpCSXB”],“portalsIn”:[],“createdAt”:1614586026594,“n”:1,“u”:1614590814437,“typeParents”:[“4RJujXanNHz75Sk6X”],“excludedTypeParents”:[],“op”:true,“s”:1614589702140,“enableBackSR”:false}

Now it’s every parentless rem created on the fly that create a new #stub instance :


Extremely annoying. :confused:

Additional question: do you think it’s normal that the copying and pasting text in RemNote language such as [[People/Authors/ftfk1]] and [[People/Authors/ftfk2]] creates a new instance of People/Authors that are parent of ftfk1 and another People/authors that is parent of ftfkt2?

I need to know if this behaviour is specific to me.

Hi @lovedebug, thanks for documenting this. We will certainly try to catch this bug as soon as we can.

@hannesfrank and @Martin, could use your expertise here.

Yes, I think that’s the intended behaviour. Since it’s possible to have multiple rems with the same name, I think RemNote is just going to create those as different rems for you. has been clarified otherwise here
Where are you copy/pasting this from?

This is quite distressing indeed. @Martin any idea how we could fix this?

Thanks for your reply =)

I’m copying and pasting from mendeley, but I don’t think it’s relevant as I have the same result from elsewhere.

The “duplicated stubs” issue was reported on Github before (not sure about the “pasting nested references” one) and Martin is very active fixing this kind of glitches.

For me both things work (again?), i.e. no duplicated rem, on both the latest desktop app and the web version:

This looks really strange. I think this is something Martin has to fix. If it does not normalize itself after the next update, you might have to open a support ticket (account issue) from within RemNote and devs will fix your database personally.

Could you show us a screenshot of your Highlight power up as well where Color > Red should be located? Is there another Red or is it missing from there then?

I thought the event timestamp may has some bugs, as different devices may have different local time due to some reasons. So the client synced event streams from server may applied wrong sequences.

1 Like

Thanks for your testing :+1:

It is annoying, but I’ve since learned that the merge utility does the trick (in the meantime).

However, the problem is still there for me (I work on desktop version 1.2.8).
Screenshot of stub created this morning (30min ago) and yesterday :

1 Like